webクリエイター加藤です。

先日、windows7のローカルに、サーバーを構築するために、XAMPPをインストールしてみました。

ま、2度目?3度目? だったので然程難しくは考えてなくて、さらーっとやってしまえばいいや!?
なんて、超カンタンに考えてました。

作業はすんなり完了して、データーベースのMysqlも問題なく動いた?んです。

一番やりたいことは、PHPを通してMysqlに接続して、データベースを使ってみることだったんですが。。。
いざやってみると、こんなエラーが。。。

o0800038412898676025

何やら、「Deprecated: mysql_connect():」ってエラーを吐き出されてしまいまして。。。
新しいVerのPHP5.5だと、データーベースに接続するには、PDO(PHP Data Object)てやつを使わないといけないようです。

これなら、古いVerのPHPでローカルにサーバーを構築しても良かったくらいです。
新しもの好きなので、最新版のXAMPPをインストールしてしまったがための。。。です。

なんでも新しければ良いってもんじゃないようですね。。

ではまた!!